تنسيقات عنوان MAC وعلاقة EUI-64
تطبيع نماذج النص الشائعة 48 بت وفهم تحويل EUI-64 المحدد.
ملخص الذكاء الاصطناعي
تعمل فواصل MAC على تغيير العرض التقديمي، وليس وحدات البايت الأساسية. التحقق من صحة المدخلات ذات ستة بايت قبل التحويل؛ التمييز بين توسعة EUI-64 العادية وتعديل EUI-64.
يمكن أن تمثل عدة سلاسل نفس الـ 48 بت
تتضمن الأمثلة 00:11:22:AA:BB:CC و00-11-22-AA-BB-CC و0011.22AA.BBCC. تحليل الثمانيات الستة بالضبط بعد إزالة الفواصل المعتمدة؛ رفض الأحرف المختلطة أو الإضافية أو غير السداسية العشرية.
الوصفة القديمة المعدلة لـ EUI-64 IID
بالنسبة لوصفة معرف واجهة IPv6 القديمة الموثقة في RFC 4291، أدخل FF:FE بين الثماني الثلاث الأولى والأخيرة من عنوان طبقة الارتباط 48 بت، ثم اعكس البت العالمي/المحلي. هذا بناء معدل لـ EUI-64 IID؛ ولا يعد هذا ادعاءً بأن الإخراج هو عنوان IPv6 الحالي للواجهة.
Input 48-bit address: 00:11:22:AA:BB:CC Insert FF:FE for legacy IID: 00:11:22:FF:FE:AA:BB:CC Invert U/L bit (Modified IID): 02:11:22:FF:FE:AA:BB:CC IPv6 IID grouping: 0211:22ff:feaa:bbcc
يجب ألا تتضمن معرفات IID المستقرة الحديثة جهاز MAC مستقرًا بشكل افتراضي
يقوم RFC 8064 بتحديث التوصية الافتراضية: استخدم RFC 7217 لمعرفات واجهة SLAAC الثابتة ولا تقم بتضمين عنوان طبقة ارتباط ثابت بشكل افتراضي. لا يمكن للقيمة ذات شكل EUI-64 وحدها أن تثبت كيفية إنشاء معرف IID.
استخدم محللًا يرفض الغموض
اختبر كل تدوين مقبول، وأحرف ست عشرية صغيرة، ومساحة صفرية، وأطوال غير صالحة، وأمثلة البث المتعدد/المحلي. احتفظ بالإدخال الأصلي للعرض أثناء استخدام وحدات البايت المقيسة للمقارنة.